lci
Stuff related to the LOLCODE interpreter, lci.
1 post Page 1 of 1
Postby lolfi » Wed Sep 10, 2014 11:12 am
This probably only applies to people setting up a vanilla build. Experienced GCC users will almost certainly have these things installed anyway and so may not encounter this issue.
This morning, I did a fresh build of Debian on Oracle VBox, tried compiling lci-<future and had a few issues to overcome before it would make:

#gcc and cmake is not enough to install. You will need these too:
apt-get update
apt-get install build-essential

#ncurses and readline libraries does not seem to be installed on Debian. These are referenced as target_link_libraries in CMakeLists.txt.
#install ncurses library:
apt-get install ncurses-dev

#try this to get readline library:
apt-get install libreadline6-dev

#or maybe this (suggested at <<https://packages.debian.org/cgi-bin/search_contents.pl?word=readline.h&searchmode=searchfiles&case=insensitive&version=stable&arch=i386>> but not tested in this build):
apt-get install libreadline-gplv2-dev

Your mileage may vary on your *nix of choice, and of course you'll have to use a different package manager.
Hope this helps,
R.xx.
1 post Page 1 of 1

Login

Who is online

Users browsing this forum: No registered users and 1 guest